From: Wakou Aoyama Date: 2000-10-12T07:24:51+09:00 Subject: [ruby-dev:11178] Re: cgi.rb 青山です。 On Thu, 12 Oct 2000 01:51:56 +0900, matz@zetabits.com (Yukihiro Matsumoto) wrote: > | pretty = " " if true == pretty > > 個人的には定数(true)が左辺だとなんだか落ち着きません。 > なんでだろ。 そうですね。if true is variable というより、if variable is true ですし ね。日本語でも「変数○が真の時」とは言いますが逆の書き方はちょっと思い 付きませんし。 しかし、Ruby 的には // === "" などの件からも、変化する可能性のあるもの を右辺というか、変化しないものを左辺という書き方になれた方が良いのかな、 と思っていたわけです。 == についても、マニュアルに「それぞれのクラスでその性質に合わせて再定 義されるべきです」とありますから、やはり確定している方を左辺にもってこ ないとなんからの危険性を含む事になるでしょうし。 ですが、確かにちょっと違和感はあるんですよね... > これがあるとruby-modeで色が変にならなくて済むというそれだけ > の理由です(安易?)。もうちょっとruby-mode.elが賢ければ良いの > ですが、色付けは理解を越えてます。 なるほど。平文だったとしても、"" の括り忘れではなく、" そのものという 事を強調するような感じにも見えますから、これでいいかもしれませんね。 -- 青山 和光 Wakou Aoyama