From: Yasushi Shoji Date: 2000-10-22T18:03:51+09:00 Subject: [ruby-dev:11279] Thread.critical= Thread.critical=の使い方なんですが、thread.rbの中でも old = Thread.critical Thread.critical = new : Thread.critical = old と、してない所があるので、使う方で Thread.criticalで囲んでも実際には critical sectionにならない場合があります。 んで、patchを送ろうかと思ったんですが、その前に質問というか提案というか。 critical sectionって true/falseの booleanで表わされていて、stackみたく働 くものですよね?それなら、それらしく Thread.critical_start : Thread.critical_end とかの方が、楽じゃないでしょうか?(なんか良い名前ないかな‥) どんなもんですか? # なんか大事なところを読み落してる様な気がするのだが‥‥。 -- yashi