From: Hugh Sasse Staff Elec Eng Date: 2000-11-08T01:48:14+09:00 Subject: [ruby-talk:6131] Re: detect:ifNone: in Ruby On Wed, 8 Nov 2000, Yukihiro Matsumoto wrote: > Hi, > > In message "[ruby-talk:6111] Re: detect:ifNone: in Ruby" > on 00/11/07, Hugh Sasse Staff Elec Eng writes: > > |> How about default, defaults or defaulting (I like the last). > | > |I'd call it "nilGives" or "nil_gives", etc. I think default leaves too > |much open -- it depends on how your objects are made as to what their > |defualt value is. > > I agree with that `default' is too broad. And both `nilGives' (case > mixture; third person) and 'nil_gives (third person) are not Rubyish > neither. nil_give perhaps? It's not a yield though... > > |This reminds me of my request for a short-circuit operator.... Is > |there a way the two can be unified, or is that silly? > > Ah, could you tell me about your short-curcuit operator idea again? > I'm too easy to forget. It was to do with sort! producing nil so that chains of methods "break" myarray.sort!.uniq!.print could raise an exception, but myarray.sort!.cut.uniq!.cut.print meant: myarray.sort! If the result is nil then do mo more of this statement otherwise myarray.uniq! and if the result is nil do no more of the statement otherwise myarray.print. But I think cut is not the right word because of its meaning in Prolog. > > matz. > Hugh