From: "Guy N. Hurst" Date: 2000-11-14T15:34:15+09:00 Subject: [ruby-talk:6347] Re: Another Smalltalk control structure idea Yukihiro Matsumoto wrote: > > The only reason I didn't put it in 1.5 (or 1.6) was I felt `inject' > did not describe the behavior enough. If you find the better name, > I'll add it immediately (to 1.7 of course). But I think you'll see it > anyway in the future. > I didn't really like the name 'inject' either. But, since it reminds me of a recursive definition in math, perhaps it could be called 'recurse'? Guy N. Hurst -- HurstLinks Web Development http://www.hurstlinks.com/ Norfolk, VA - (757)623-9688 PHP/MySQL - Ruby/Perl - HTML/Javascript