From: matz@... (Yukihiro Matsumoto) Date: 2000-11-07T12:50:25+09:00 Subject: [ruby-talk:6095] Re: detect:ifNone: in Ruby Hi, In message "[ruby-talk:6092] Re: detect:ifNone: in Ruby" on 00/11/07, Aleksi Niemel� writes: |Don't forget the block form. | | x = a.detect {|i| i == 7}.ifNil { 99 } | |And I guess name should be without '?'. Otherwise great extension. (Is it ok |to call it extension or am I overloading too much?) I don't vote for `ifNil' with or without `?'. With `?' it too looks like `nil?'. Without `?', the name convention is Smalltalkish, not Ruby way. If we can find better name, I agree to add the method to the next version. matz.