From: matz@... (Yukihiro Matsumoto) Date: 2000-11-08T01:10:41+09:00 Subject: [ruby-talk:6129] Re: detect:ifNone: in Ruby Hi, In message "[ruby-talk:6111] Re: detect:ifNone: in Ruby" on 00/11/07, Hugh Sasse Staff Elec Eng writes: |> How about default, defaults or defaulting (I like the last). | |I'd call it "nilGives" or "nil_gives", etc. I think default leaves too |much open -- it depends on how your objects are made as to what their |defualt value is. I agree with that `default' is too broad. And both `nilGives' (case mixture; third person) and 'nil_gives (third person) are not Rubyish neither. |This reminds me of my request for a short-circuit operator.... Is |there a way the two can be unified, or is that silly? Ah, could you tell me about your short-curcuit operator idea again? I'm too easy to forget. matz.