From: Hidetoshi NAGAI Date: 2003-07-21T01:42:55+09:00 Subject: [ruby-dev:20736] Re: portable(?) UserID/GroupID control 永井@知能.九工大です. From: matz@ruby-lang.org (Yukihiro Matsumoto) Subject: [ruby-dev:20735] Re: portable(?) UserID/GroupID control Date: Mon, 21 Jul 2003 00:34:06 +0900 Message-ID: <1058715357.750868.22492.nullmailer@picachu.netlab.jp> > ruby-listにもポストしておられますが、あちらでの議論を邪魔し > ないためにこちらで話します。私の意見が必要以上に重視されるこ > とを防ぐためです。 はい.承知しました. # 議論場所の発散が嫌で,しばらくの間,流すかどうか迷っていたのですが, # やはり反応が欲しかったもので ruby-list にまで流してしまいました. # このままだと,前回の二の舞でまた放置状態になりそうでしたので... > In message "[ruby-dev:20690] portable(?) UserID/GroupID control (Re: frozen ThreadGroup)" > on 03/07/16, Hidetoshi NAGAI writes: > > |module Process::UserID ユーザ ID 操作 > > これ、Process::UIDはいかがでしょう。GroupIDはGIDということで。 全く異存ありません. UID, GID だと略しすぎと見なされるかもと思って UserID, GroupID としていましたが, UID, GID で問題ないならその方がいいですよね. ところでシステムコールを直接提供する方はどうしましょう? とりあえず現在の Process モジュールから切り放すために Process::ID_Syscall モジュールというようにしていますが, 実は私自身,いい名前だとは思っていません. Process モジュールに追加という考え方もあるとは思いますが, OS への依存性が強いものを多量に追加するのは少し問題ありとも感じます. この点,どう思われますでしょうか? > re_exchangeとre_exchangeable?は良いと思います。長いですが、 > さほど頻繁に使う機能でもなし。 > > あと、ridはrealとしたいところですが、そうするとeidが > effectiveなんて長い名前になってバランスが悪くなるので、これ > はrid/eidで妥協しても良いかなと思います。 では ruby-list ML の方でも大きな異論がなければ これらについては OK ということでも良さそうですね. # rid / eid とした理由は正にご指摘の通りでした. > Rubyのメソッド名は「動詞は原形を使う」というルールを採用して > いるので、has_sid?はhave_sid?またはsid?とかsid_available?な > どになるべきです。 すみません.そういうルールでしたね. sid? では sid についての何を尋ねているのかがわからないですし, sid_available? では長いので,have_sid? を最優先候補に ...と最初は思いましたが,re_exchangable? との対比を考えると sid_available? はいいですね. re_exchangeable? と同様,頻繁に使うメソッドではないので, 少々長いものの sid_available? を最優先候補としたいと思います. > switchには賛成します。 ありがとうございます. > 残りはto(id)とeid=(id)ですが、これらは名前から機能が想像でき > ません。別の名前を希望します。ハフマンエンコーディングの観点 > から言えば、メソッド名は長くても良いと思います。 to(id) はともかく,eid=(id) もダメでしたか? 確かに保存ユーザ ID への影響があるかもしれない点は メソッド名には表れていませんが,effective ID に 値を設定するという意味合いは表れていると思ったのですが... 両メソッドとも他の名前候補を考えてみます. -- 永井 秀利 (九工大 知能情報) nagai@ai.kyutech.ac.jp