From: Sean Russell Date: 2001-06-29T23:36:03+09:00 Subject: [ruby-talk:17063] Re: RCR for the String class -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 On Thursday 28 June 2001 19:00, you wrote: > Yeah... Ya know what I don't like about Ruby? The class names are too > short. And there aren't enough of them. I want a BufferedReader and a > BufferedInputStream and a ByteArrayInputStream and a > LeftThirdToenailClipper too. It really grates on me that I don't need a > couple of 4-inch-thick books on the desk next to me when I want to get > something simple done. Ooh, ooh... and another thing I hate about Ruby. All of those Object thingies. Why can't we have the simplicity of C, where everything is a function? Why go through all the trouble of this "encapsulation" stuff? What a bother. Oh, and I also hate people who choose descriptive variable names, like "count" and "max_people". I'd much rather read code that uses variables such as "x", "y", "i" exclusively. Dang, I don't know why I bother to use Ruby at all. You can REALLY pack a lot of code into one line in Perl! It's the ultimate language! Seriously, though, the names of the classes is moot. You could call them X and Y if you want, for all I care. As long as I don't have to read your code. The point I was trying to make is that Java, in general, does a better job of hiding the implementation details than Ruby does in some of the core classes, and is in /that/ way more OO than Ruby. And, yes... some naming conventions in Ruby such as "to_i", "to_a", and "to_s" bother me a bit. There is the assumption that people will know that "to_i" stands for "to_integer", which implies that "integers" are special, not like other objects, in some way. This mirrors Java's special treatment of primatives in attitude, if not in implementation. I vastly prefer Ruby to Java, but that doesn't mean that I wouldn't have done some things a bit differently had I had the great genius to invent Ruby. Luckily, I can create a library to include in my programs that renames or changes (almost) anything about Ruby that I don't like. I can not do this in Java, and therein lies part of the reason I choose Ruby over Java when I can. - --- SER Deutsch|Esperanto|Francais|Linux|Java|Dirigibles|GPG|Pegwit "Did you ever notice that while MS stands for Microsoft, it also stands for the dread disease Multiple Sclerosis? Well, why not? They're both slow, crippling and ultimately deadly." -- Monika McDole -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.0.4 (GNU/Linux) Comment: For info see http://www.gnupg.org iD8DBQE7PJJKP0KxygnleI8RAnovAJ9GA7QtJm/zvcNAZl58GsGyKWPbzACgk4Hl 1UDS/92/PkdH0YgyPUpPA6s= =/cwn -----END PGP SIGNATURE-----