From: Avi Bryant Date: 2001-06-16T10:06:51+09:00 Subject: [ruby-talk:16524] Re: Smalltalk vs. Ruby On Sat, 16 Jun 2001, Wayne Blair wrote: > Sure, but what we're saying is that this is easier to read: > > connect(someLocation) > { |connection| > ... > } Well, sure, but I thought connect(someLocation) do |connection| ... end was actually pretty close to connect: someLocation do: [ :connection | ...] if we're going for pseudo-smalltalk.