From: Kazuhiro Nishiyama Date: 2000-03-13T05:14:32+09:00 Subject: [ruby-list:21357] [book]6,7 章 http://www.ruby-lang.org/ja/book/errata/ruby.html がいつ更新されるのかが気になりますが、最近読んだところのerrata等です。 p.320,321 (A-0) リスト6-29 @lex_state p.321の説明 @status となってます。どっちが正しいのでしょうか? p.355 リスト7-16 def +(m)の中の when Matrix else when Matrixには意味があるのでしょうか? p.358 リスト7-18 Matrix::Scalerの除法の定義→ リスト7-18 Matrix::Scalarの除法の定義 p.368 Module#instance_eval→ Module#module_eval p.371 リスト7-22(p.545と同じ修正) ali = ali.id2name if methond.kind_of?(Integer)→ ali = ali.id2name if method.kind_of?(Integer)じゃなくて(^^; ali = ali.id2name if ali.kind_of?(Integer) 最近のruby-devをみてるとunless 〜.kind_of?(String)の方が良さそうな気も。 同リスト7-22 alias def_delegators def_instanse_delegators→ alias def_delegators def_instance_delegators alias def_delegator def_instanse_delegator→ alias def_delegator def_instance_delegator p.370の説明にあるdef_delegateはどこ? p.372 #(1.2)委譲しなくてはならないメソッドを削除→ #(1.2)委譲するメソッドを削除 わかりやすい言葉で書いてあった方がいいのではないでしょうか? p.373 (1.2) 委譲元のオブジェクトで評価した方がいいので委譲することにします→ 委譲先のオブジェクトで評価した方がいいので委譲することにします。 p.374 (1)で収集した委譲すべきでないメソッド→ (1)で収集した委譲しないメソッド リスト7-23で「(1)で収集した委譲しないメソッド」と書いてあるので。 p.376 ・Name2Class:クラス名とクラス(オブジェクト)へのハッシュ表→ ・Name2Class:クラス名からクラス(オブジェクト)へのハッシュ表 ・Name2SubclassNames:(略)の配列のハッシュ表→ ・Name2SubclassNames:(略)の配列へのハッシュ表 p.378 @InstanceMwthod_BW→@InstanceMethod_BW p.379 TkButtom→TkButton p.385 @time_stampe→@time_stamp --- ZnZ(ゼット エヌ ゼット) 西山和広(Kazuhiro Nishiyama) mailto:nishiyama@mx1.tiki.ne.jp