From: "David A. Black" Date: 2005-08-25T04:08:15+09:00 Subject: Re: Pathname#walk for traversing path nodes (patch) Hi -- On Thu, 25 Aug 2005, mathew wrote: > ES wrote: > >> The absolute best name would be simply #each (incidentally, looks like >> it would be available). That failing, #walk, #traverse or #each_node. > > > I'd like to suggest "descend", because it's really descending into the path > provided. The thing is, though, it isn't really descending. The path may not even exist. It's just moving from left to right through a bunch of tokens, which may or may not correspond to a real filesystem. If it were really a full traversal, you'd get: a a/b a/b/c a/b/c/d *plus* whatever else branched off of b, c, and d. whereas what we're talking about here, as I understand it, is: a b c d which is much more just a list of components than a recursive traversal. David -- David A. Black dblack@wobblini.net