From: "David A. Black" Date: 2005-08-23T22:45:27+09:00 Subject: Re: Pathname#walk for traversing path nodes (patch) Hi -- On Tue, 23 Aug 2005, daz wrote: > > David A. Black > >> >> On Tue, 23 Aug 2005, daz wrote: >> >>> >>> Tanaka Akira wrote: >>> >>>> David A. Black writes: >>>> >>>>> Maybe "scan". >>>> >>> >>> I've followed the recent protests that a Pathname is not >>> a String and, here, the name of a String method is >>> suggested. An understanding of the operation of either >>> #scan method would provide no clue to the operation of >>> the other. >>> This, IMHO, is what leads to dilution of meaning, >>> then dilution of understanding. I object strongly. >> >> I don't think any given class can monopolize a method name, unless >> there's a really close connection. (And in that case it would be >> monopolization by default, since no other objects would want the >> name.) >> > > Perhaps - but I think the name "scan" should be reserved for > methods which are doing some kind of scanning (i.e. discovery) > rather that iterating over components which are invariant and > well understood by the class. My first choice would actually be split, but that's already in use for this class. David -- David A. Black dblack@wobblini.net