From: Tanaka Akira Date: 2009-06-01T20:23:40+09:00 Subject: [ruby-dev:38560] Re: Enumerable#gather_each In article , Yukihiro Matsumoto writes: > これについては反対しませんので、これらもRDocに追加してもらえ > ませんか。ちょっと冗長過ぎるかなあ。 ドキュメントに足すのは問題ありません。 > そうですね。_by系でシンボルで制御すると言う前例がない、とい > うこと以外には、気になる点はありません。 たしかにその前例はない気がしますね。 > そうですよね。対応するものがslice_byである時に、_byと_before > というのが、意味的に対応しない気がするというのが違和感の根源 > のような気がします。 では、どちらかを slice じゃなくて chunk にするのはどうでしょうか。 chunk_by と slice_before あるいは slice_by と chunk_before ということですが。 -- [田中 哲][たなか あきら][Tanaka Akira]