From: SASADA Koichi Date: 2010-10-15T17:09:21+09:00 Subject: [ruby-dev:42394] Re: [Feature: trunk] GC.stat  ささだです。 (2010/10/15 8:58), Tanaka Akira wrote: > 2010年10月15日16:32 SASADA Koichi : > >>> |に、GC.internal_statistic_information という感じで追加するのはどうでしょ >>> |うか。 >>> >>> うーん、いくらなんでもそんな名前は嫌です。GC.statでいいじゃ >>> ん。そこに反対したことはありません。 >> >>  反対してたのは田中さんなんで...。 > > GC.stat に反対した覚えはありませんね。 > 反対なのは返り値の中に含まれる heap という語についてです。  はい。なので、 1. stat という使いやすい名前じゃなければいいのか、 2. ドキュメントにあればいいのか、 3. ソースを変えない限り駄目なのか、 って話で、1案を提案してみました。  2案で良ければ、2案が良いです。 -- // SASADA Koichi at atdot dot net