From: Tanaka Akira Date: 2009-06-15T20:47:48+09:00 Subject: [ruby-dev:38635] Re: [Feature: trunk] GC.stat In article <4A3612EF.1080008@atdot.net>, SASADA Koichi writes: >  何がいいでしょう.例えば,slot_length, ... とかにして,live_slot とか > にするとか. なにがいいですかねぇ。 slot は、HEAP_MIN_SLOTS などをみると、オブジェクトの場所とい う意味で使われていて違うんじゃないかと思いますが。 >  まぁ,heap* は,所詮 Ruby の実装を知ってる人しかわからないので,別にい > いような気もするんですが.例えば,GC::Profiler なんかも,知らないとわか > らない内容な気がします. 公開のメソッドにすれば、Ruby の実装を知らないひとが興味を持 つことは充分に考えられるでしょう。 実装を知っているひとしかわからなくていいといういいわけは、よ り通用しにくくなるんじゃないでしょうか。 -- [田中 哲][たなか あきら][Tanaka Akira]