From: SASADA Koichi Date: 2010-10-15T16:32:45+09:00 Subject: [ruby-dev:42391] Re: [Feature: trunk] GC.stat  ささだです。 (2010/10/15 2:00), Yukihiro Matsumoto wrote: > | この件、キーの名前をどうするかでちゅうぶらりんになっていました。実装の > |詳細に踏み込んだ、処理系開発者しか見ないメソッドという意味を強調するため > |に、GC.internal_statistic_information という感じで追加するのはどうでしょ > |うか。 > > うーん、いくらなんでもそんな名前は嫌です。GC.statでいいじゃ > ん。そこに反対したことはありません。  反対してたのは田中さんなんで...。 > ドキュメントにGC.statは処理系依存で、戻り値は(最低限の共通項 > 以外)バージョン依存であると明記するのでどうでしょうか。  はい。それでいいなら、それが良いです。 -- // SASADA Koichi at atdot dot net