From: SASADA Koichi Date: 2009-06-14T02:07:50+09:00 Subject: [ruby-dev:38604] Re: [Feature: trunk] rb_objspace_each_objects  ささだです. Yukihiro Matsumoto wrote:: > * each_objectと単数形ではないだろうか  なんて名前がいいでしょうかね. > * VALUE*ではなくVALUEではないだろうか  そうでした.で,VALUE だと足しても次の領域には行かないから,拡張ライブ ラリ向けには struct RObject * にでもするといいのかなぁ.RVALUE を gc.c から ruby.h に持って行くのも一案ですが.... > |*ST_CONTINUE みたいなのを使ってしまったんですが, > | これは行儀が悪い気がする.どうするべき? > > ST_CONTINUEはst_table用ですから、本来はobject_each用の定数を > 用意すべきでしょうね。  わかりました. -- // SASADA Koichi at atdot dot net