From: "shugo (Shugo Maeda)" <redmine@...>
Date: 2012-11-22T13:23:06+09:00
Subject: [ruby-core:49850] [ruby-trunk - Feature #7418][Assigned] Kernel#used_refinements


Issue #7418 has been updated by shugo (Shugo Maeda).

Status changed from Open to Assigned
Assignee set to shugo (Shugo Maeda)

judofyr (Magnus Holm) wrote:
> Maybe it should be called Module.refinements (a la Module.nesting).

Module.refinements conflicts with Module#refinements, which returns refinements defined in the receiver.

----------------------------------------
Feature #7418: Kernel#used_refinements
https://bugs.ruby-lang.org/issues/7418#change-33462

Author: charliesome (Charlie Somerville)
Status: Assigned
Priority: Normal
Assignee: shugo (Shugo Maeda)
Category: 
Target version: 


I'd like to propose a method that returns an array of all refinements visible from the current scope. I have documented the ordering of the return array as undefined to allow a bit of flexibility in how it is implemented across the various Ruby implementations.

One of the criticisms of refinements is that its use makes code harder to understand - especially when non-lexical refinements are being used. This method slightly improves the situation by making debugging of code using refinements easier.

I've named the method 'used_refinements' for now, but I'm open to changing that to something else.

I've already done the initial implementation which is attached as a patch. Feedback would be most appreciated.


-- 
http://bugs.ruby-lang.org/