From: "nobu (Nobuyoshi Nakada)" Date: 2012-07-09T17:40:32+09:00 Subject: [ruby-core:46264] [ruby-trunk - Feature #6693][Feedback] Don't warn for unused variables starting with _ Issue #6693 has been updated by nobu (Nobuyoshi Nakada). Status changed from Closed to Feedback % Done changed from 100 to 50 Sorry, missed [ruby-core:46170]. Now I incline to revert the commit. Any idea? ---------------------------------------- Feature #6693: Don't warn for unused variables starting with _ https://bugs.ruby-lang.org/issues/6693#change-27888 Author: marcandre (Marc-Andre Lafortune) Status: Feedback Priority: Low Assignee: Category: core Target version: 2.0.0 Currently, variables which are set but not used will generate a warning (ruby -w), except if they have the special name "_". So best practice is to use "_" for all unused variables. This does not encourage readable code. # Currently must read: _, _, _, suffix = parse_name # could read: _first, _middle, _last, suffix = parse_name We should not warn for unused variables starting with a "_". This would create an option (but no obligation) to use more descriptive names than "_" without generating warnings. -- http://bugs.ruby-lang.org/