From: "nobu (Nobuyoshi Nakada)" Date: 2012-07-15T06:27:14+09:00 Subject: [ruby-core:46481] [ruby-trunk - Feature #6721] Object#yield_self Issue #6721 has been updated by nobu (Nobuyoshi Nakada). I'm not against the feature itself, but don't like the name. ---------------------------------------- Feature #6721: Object#yield_self https://bugs.ruby-lang.org/issues/6721#change-28122 Author: alexeymuranov (Alexey Muranov) Status: Open Priority: Normal Assignee: Category: Target version: =begin I think the following method is missing from Ruby: class Object def yield_self(*args) yield(self, *args) end end I do not know a good use case, but it looks very natural to me. It can be used in method chains. What do you think? Is there an alternative? =end -- http://bugs.ruby-lang.org/