From: "mame (Yusuke Endoh)" Date: 2012-10-27T12:04:20+09:00 Subject: [ruby-core:48442] [ruby-trunk - Feature #6693] Don't warn for unused variables starting with _ Issue #6693 has been updated by mame (Yusuke Endoh). Target version changed from 2.0.0 to next minor ---------------------------------------- Feature #6693: Don't warn for unused variables starting with _ https://bugs.ruby-lang.org/issues/6693#change-31769 Author: marcandre (Marc-Andre Lafortune) Status: Feedback Priority: Low Assignee: matz (Yukihiro Matsumoto) Category: core Target version: next minor Currently, variables which are set but not used will generate a warning (ruby -w), except if they have the special name "_". So best practice is to use "_" for all unused variables. This does not encourage readable code. # Currently must read: _, _, _, suffix = parse_name # could read: _first, _middle, _last, suffix = parse_name We should not warn for unused variables starting with a "_". This would create an option (but no obligation) to use more descriptive names than "_" without generating warnings. -- http://bugs.ruby-lang.org/