From: "boris_stitnicky (Boris Stitnicky)" Date: 2013-05-18T05:41:55+09:00 Subject: [ruby-core:55032] [ruby-trunk - Feature #6721] Object#yield_self Issue #6721 has been updated by boris_stitnicky (Boris Stitnicky). nobu (Nobuyoshi Nakada) wrote: > I'm not against the feature itself, but don't like the name. +1 to this opinion ---------------------------------------- Feature #6721: Object#yield_self https://bugs.ruby-lang.org/issues/6721#change-39386 Author: alexeymuranov (Alexey Muranov) Status: Open Priority: Normal Assignee: matz (Yukihiro Matsumoto) Category: core Target version: next minor =begin I think the following method is missing from Ruby: class Object def yield_self(*args) yield(self, *args) end end I do not know a good use case, but it looks very natural to me. It can be used in method chains. What do you think? Is there an alternative? =end -- http://bugs.ruby-lang.org/