From: "drbrain (Eric Hodel)" Date: 2012-08-14T03:48:17+09:00 Subject: [ruby-core:47159] [ruby-trunk - Feature #6693] Don't warn for unused variables starting with _ Issue #6693 has been updated by drbrain (Eric Hodel). Why should we break compatibility with ruby 1.9? RDoc uses double assignment to avoid the unused variable warning for use by ERb via a binding. The syntax error would break RDoc, so I dislike it. ---------------------------------------- Feature #6693: Don't warn for unused variables starting with _ https://bugs.ruby-lang.org/issues/6693#change-28839 Author: marcandre (Marc-Andre Lafortune) Status: Feedback Priority: Low Assignee: Category: core Target version: 2.0.0 Currently, variables which are set but not used will generate a warning (ruby -w), except if they have the special name "_". So best practice is to use "_" for all unused variables. This does not encourage readable code. # Currently must read: _, _, _, suffix = parse_name # could read: _first, _middle, _last, suffix = parse_name We should not warn for unused variables starting with a "_". This would create an option (but no obligation) to use more descriptive names than "_" without generating warnings. -- http://bugs.ruby-lang.org/