From: maili31s@... (SugHimsi==SUGIHARA Hiroshi) Date: 2003-11-27T07:01:13+09:00 Subject: [ruby-list:38839] Re: ruby-dev summary: 21928-22011 すぎむし。 On Thu, 27 Nov 2003 03:53 JST, Masayoshi Takahashi wrote: : [ruby-dev:21932] rough / tabs.rb : : Minero Aoki reviewed tabs.rb in rough directory in CVS in重複。in CVS rough (directory)だとか? : because he wanted a standard library to treat tabs. But : he have some complaints of that, so he rewrote new one. had : * much faster than original in difficult case : * nearly fast in normal case (some tabs in line head) : * bang method is slower than non-bang method : : He thought: : : * is it much suitable to name expand_tabs when it's in String class? His thoughts: * better name for expand_tabs in the case it is in ... : FYI: : google(expandtab) = 13900 これ、要りますか? : [ruby-dev:21933] new hash literal : : Nobu Nakata saw Matz's slides Nakada read RC2003 slides 読んだことに。 : [ruby-dev:21955] block local parameters in Ruby2 : : Shugo Maeda saw Matz's slides of RC2003 and found a notation: read 同上。 : * Block parameters will be block local : even if variables with same names exist : : But he thought a sample like below should raise an error. ^\_ that : Maeda and Matz feel that the style like that is 短く。 Shugo such style is ugly, but ... : [ruby-dev:21990] environment variables in ruby.1 : [ruby-dev:22000] purge pthread at configure パス。 以上 -- SugHimsi == SUGIHARA Hiroshi maili31s@clio.ne.jp preview3を待ってたんじゃなくてよかった。