From: Mark Hubbart Date: 2005-04-15T02:38:58+09:00 Subject: Re: want_object? - possible? On 3/24/05, Austin Ziegler wrote: > On Wed, 23 Mar 2005 02:38:54 +0900, Berger, Daniel > wrote: > > I suppose there's the danger of the slippery slope, where we start > > adding more and more context checking methods, like want_lvalue?, > > want_rvalue?, etc, and things get out of control. > > Um. I oppose this for the sole reason that it looks, smells, sounds, > and feels far too much like wantarray from Perl. I think that is one > of Perl's nastiest features. I wholly agree with that. Perhaps a different name would have less stink. "uses_return_value?", perhaps? Or maybe "needs_return_value?". I think that's a little more descriptive, to boot; it lets you know there's a little magic going on behind the scenes. I am still unsure as to whether this would be a good idea, I haven't run through all the potentials for abuse yet. And i don't know if it would even be possible to implement. cheers, Mark