From: Shugo Maeda Date: 2009-08-05T09:36:26+09:00 Subject: [ruby-dev:39018] Re: セキュリティモデルのドキュメント 前田です。 2009/08/05 2:00 に Kazuhiro NISHIYAMA さんは書きました: >> 違います。 > > untrust で検索して違いをチェックしていたら見落としてしまっていました。 untrustという用語を入れた方がわかりやすいかもしれないですね。 もともとの名前が悪いので、「untrustedでない」のように二重否定に なってしまいますが...。 > 変更の意図を考えると > > module Kernel > unless method_defined?(:untrust) > alias untrust taint > end > end > > のように untrust が無ければ定義して、taint の代わりに > untrust を使うべきなのでしょうか? はい、意図を明確にするためには、その方が望ましいように思います。 -- Shugo Maeda