From: Dave Thomas Date: 2002-09-07T01:53:57+09:00 Subject: Re: Patch to add a Module#const_missing method matz@ruby-lang.org (Yukihiro Matsumoto) writes: > |proxy classes for Java classes. I guess there must be some similar uses > |for it in C-Ruby too, for creating proxy classes? > > Understood. How about more general aproach like "attr_missing" or > something to hook both instance variables and constants? Of course, > there may be a better name. > I wonder if there's any reasonable case where you'd want a single method to be able to handle both missing instance variables and missing constants? The two seem pretty disjoint, so perhaps they should use different hooks. Cheers Dave