From: matz@... (Yukihiro Matsumoto) Date: 2002-09-07T01:39:57+09:00 Subject: Re: Patch to add a Module#const_missing method Hi, In message "Re: Patch to add a Module#const_missing method" on 02/09/06, Anders Bengtsson writes: |> Thank you for the patch. But we have to discuss whether we need this |> hook. Hook is sometimes useful but since we can not add every |> possible hook, we have to draw line somewhere. Opinion, everyone? | |Jan Arne has already implemented it in JRuby, where we needed to create |proxy classes for Java classes. I guess there must be some similar uses |for it in C-Ruby too, for creating proxy classes? Understood. How about more general aproach like "attr_missing" or something to hook both instance variables and constants? Of course, there may be a better name. matz.