From: Nobuyoshi Nakada Date: 2007-06-01T14:39:18+09:00 Subject: [ruby-dev:30867] Re: Supporting Fiber なかだです。 At Fri, 1 Jun 2007 13:59:22 +0900, Leonard Chin wrote in [ruby-dev:30866]: > > (3) API 名は適当でしょうか? > > で、いろいろメソッド名を考えてみました。 > > > > > > class Fiber > > alias start pass # 初回以外でも使えていいものか (*) > > alias restart pass # 初回に使えていいものか > > alias resume pass # suspend してないのに使えていいものか > > alias kick pass > > alias call pass # call だと、対等の関係じゃないっぽい > > alias goto pass # fib.goto は変だ > > alias yield pass # 機能紛らわしくない? > > alias transit pass > > Fiber#abdicate # "Fiber A abdicates control to Fiber B" > Fiber#bequeath # "Fiber A bequeaths control to Fiber B" > Fiber#bestow # "Fiber A bestows control to Fiber B" > Fiber#cede # "Fiber A cedes control to Fiber B" > はいかがでしょうか? > いずれも「yield」と少し似ていて、またはswitchと違っていて、 > _toを付け加えなくても「AからBへ譲る」のニュアンスがあります。 それは全部Aが主語でBが目的語ですよね。今のFiber#passでは Fiber.currentからレシーバに制御が渡るので、方向が逆ではないかと 思います。Fiberのクラスメソッドなら Fiber.bestow(fiberB) でもいいのでしょうが。 なにか、「任される」というような単語はないでしょうか。 # Fiber#have_control -- --- 僕の前にBugはない。 --- 僕の後ろにBugはできる。 中田 伸悦