From: Nobuyoshi Nakada Date: 2007-06-21T10:25:22+09:00 Subject: [ruby-dev:31033] Re: rb_get_interned なかだです。 At Thu, 21 Jun 2007 01:41:25 +0900, Yukihiro Matsumoto wrote in [ruby-dev:31032]: > |> | ID rb_get_interned(const char *name, long len); > |> | > |> |のような形で既存の名前だけを探すというのはどうでしょうか。 > |> > |> 名前が気に入らない。 > | > |引数はOK? > | > |rb_registered_id() > |rb_interned_p() > |とか。 > > うーん、それだったら純粋に元々のrb_sym_interned_p()を復活させ > るのがよいように思います。引数については、M17N化した時にエン > コーディング情報を得ることができるようにVALUEである方がありが > たいです。 となるとrb_intern2()はどうなるんでしょう。rb_str_intern()を代替 に? もうひとつ、rb_sym_interned_p()の復活も反対ではないんですが、ID を返す関数としてはちょっと名前に違和感ないですか。 -- --- 僕の前にBugはない。 --- 僕の後ろにBugはできる。 中田 伸悦