From: Tanaka Akira Date: 2007-06-09T00:26:24+09:00 Subject: [ruby-dev:30935] Re: secrand.rb In article <46694461.4060706@sarion.co.jp>, "NAKAMURA, Hiroshi" writes: > SecureRandomがいいと思います。SecRand / secrandは、確立された略称でもな > いと思いますし、新規に略称として導入するほどの名称のようには、私は思いま > せん。SecureRandomの場合、ファイル名はsecurerandom.rb。 ふむ。それは考えたのですが、長すぎると思ってやめたのです。 securerandom.rb は 16文字で、lib 以下で一番長い resolv-replace.rb の 18文字に次いで長くなります。 resolv-replace.rb はクラス・モジュール名には対応しませんから、 クラス・モジュール名でいえば (たぶん) 一番長くなります。 まぁ、resolv-replace.rb (や、その次に長い prettyprint.rb) の ことを考えると私がいうのもなんですが、やっぱり長すぎるのは ちょっとよろしくないと (反省も込めて) 思うのです。 > また、関数呼び出し形式は必要でしょうか。コンストラクタ的でないSecRandモ > ジュールに、SecRand関数はそぐわないような気がします。こちらは関数形式に > 対する、個人的な思いですが。 そういわれてみると、これは無くてもいいかもしれません。 あるいは、SecRand のモジュール関数にするか。 -- [田中 哲][たなか あきら][Tanaka Akira]