From: vruz Date: 2004-09-03T05:33:03+09:00 Subject: Re: "destructiveness" of delete > There were no big reason than "they had different origins" as I stated > before. Probably it was wrong naming, I admit. I'm afraid that > unifiying behavior (to either direction) would cause serious problems > more than it would solve. Any realistic idea, anyone? idea: for the next release, create an alias String#delete_char for String#delete, and deprecate String#delete until next major release, then effectively dropping it in two major releases from now. This approach has been used before to differentiate "each" from "each_line". On Thu, 2 Sep 2004 10:03:51 +0900, Yukihiro Matsumoto wrote: > Hi, > > In message "Re: "destructiveness" of delete" > on 04/09/01, "David A. Black" writes: > > |I don't either, but I think the question of how "delete" relates to > |"delete!" is separate. I would favor unification, not because strings > |should be similar to arrays but to avoid having two conflicting > |rationales (even if one of them has been forgotten :-) for how > |"delete[!]" relates to its receiver. > > There were no big reason than "they had different origins" as I stated > before. Probably it was wrong naming, I admit. I'm afraid that > unifiying behavior (to either direction) would cause serious problems > more than it would solve. Any realistic idea, anyone? > > matz. > > -- --- vruz