From: Al Snow Date: 2019-05-31T00:08:34+00:00 Subject: [ruby-core:92900] Results of my upgrading my 64 "canary" repos to Ruby 2.7.0-preview1 --===============1747128144== Content-Language: en-US Content-Type: multipart/alternative; boundary="_000_BYAPR05MB3957A8EFDD2D959A73274F4DC1190BYAPR05MB3957namp_" --_000_BYAPR05MB3957A8EFDD2D959A73274F4DC1190BYAPR05MB3957namp_ Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable FYI: Results of my upgrading my 64 "canary" repos to Ruby 2.7.0-preview1 LEGEND: Column 1 (a number) below is number of repo's (sort|uniq -c). 1. Did not try to use Rails 4.1 or below repos: These 9 repos are not in the 64 count. 2 rvm use 2.3.8@ruby2.3.8-rails3.0 --create 1 rvm use 2.3.8@ruby2.3.8-rails3.1 --create 3 rvm use 2.3.8@ruby2.3.8-rails3.2 --create 1 rvm use 2.3.8@ruby2.3.8-rails4.0 --create 1 rvm use 2.3.8@ruby2.3.8-rails4.1 --create 1 rvm use 2.4.6@ruby2.4.6-rails2.3 --create 2. Successfully upgraded 59 repos on GitHub/Bitbucket. 17 rvm use 2.7.0-preview1@ruby2.7-no-rails --create 2 rvm use 2.7.0-preview1@ruby2.7-rails5.1 --create 5 rvm use 2.7.0-preview1@ruby2.7-rails5.2 --create 28 rvm use 2.7.0-preview1@ruby2.7-rails6.0 --create 7 rvm use 2.7.0-preview1@ruby2.7-rails6.1 --create 3. 5 repos are WIP (see 3a, 3b, 3c, 3d). 1 rvm use 2.6.3@ruby2.6-rails5.1 --create 1 rvm use 2.6.3@ruby2.6-rails5.2 --create 1 rvm use 2.6.3@ruby2.6-rails6.1 --create 2 rvm use 2.6.0-preview2@ruby2.6-rails4.2 --create 3a. Need support for bundler 1.7 and 2.x in same repo. -- Rails <=3D 4.2 (Ruby pre-2.7.x needs bundler 1.7.x) with Rails >=3D 5.x (and Ruby 2.7.x wants bundler 2.x). Examples: TravisCI martix, appraisals matrix 3b. Unclear location/trigger for this error. -- TypeError: no implicit conversion of String into Integer Maybe related to bootsnap gem. Added comment to their issue #258. More debugging will be needed to identify trigger. 3c. Non-blocking dependency warning for Proc.new. -- Getting below warning for old versions of Rails and gems (so far: faraday, will_paginate). -- "Warning: Capturing the given block using Proc.new is deprecated; use `&block` instead 3d. Rails 4.2 repos wanted bundler 1.7.x and Ruby 2.7.x wants bundler 2= .1.x. THANKS for all the hard work ya'll do on Ruby. Hope this is helpful and informative, Al --_000_BYAPR05MB3957A8EFDD2D959A73274F4DC1190BYAPR05MB3957namp_ Content-Type: text/html; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable
FYI: Results of my upgrading my 64 "canary" rep= os to Ruby 2.7.0-preview1

LEGEND: Column 1 (a number) below is number of repo's (sort|uniq -c).<= br>

 1. Did not try to use Rails 4.1 or below repos:
    These 9 repos are not in the 64 count.
    2 rvm use 2.3.8@ruby2.3.8-rails3.0 --create
    1 rvm use 2.3.8@ruby2.3.8-rails3.1 --create
    3 rvm use 2.3.8@ruby2.3.8-rails3.2 --create
    1 rvm use 2.3.8@ruby2.3.8-rails4.0 --create
    1 rvm use 2.3.8@ruby2.3.8-rails4.1 --create
    1 rvm use 2.4.6@ruby2.4.6-rails2.3 --create

 2. Successfully upgraded 59 repos on GitHub/Bitbucket.
    17 rvm use 2.7.0-preview1@ruby2.7-no-rails --create
     2 rvm use 2.7.0-preview1@ruby2.7-rails5.1 --create=
     5 rvm use 2.7.0-preview1@ruby2.7-rails5.2 --create=
    28 rvm use 2.7.0-preview1@ruby2.7-rails6.0 --create
     7 rvm use 2.7.0-preview1@ruby2.7-rails6.1 --create=

 3. 5 repos are WIP (see 3a, 3b, 3c, 3d).
    1 rvm use 2.6.3@ruby2.6-rails5.1 --create
    1 rvm use 2.6.3@ruby2.6-rails5.2 --create
    1 rvm use 2.6.3@ruby2.6-rails6.1 --create
    2 rvm use 2.6.0-preview2@ruby2.6-rails4.2 --create

    3a. Need support for bundler 1.7 and 2.x in same repo.
        -- Rails <=3D 4.2 (Ruby pre-2.7.x needs= bundler 1.7.x)
           with Rails >=3D 5.x (and R= uby 2.7.x wants bundler 2.x).
           Examples: TravisCI martix, ap= praisals matrix

    3b. Unclear location/trigger for this error.
        -- TypeError: no implicit conversion of St= ring into Integer
            Maybe related to bootsnap ge= m. Added comment to their issue
           #258. More debugging will be = needed to identify trigger.

    3c. Non-blocking dependency warning for Proc.new.
        -- Getting below warning for old versions = of
            Rails and gems (so far: fara= day, will_paginate).
            -- "Warning: Capturing = the given block using
                Proc.new is de= precated; use `&block` instead

    3d. Rails 4.2 repos wanted bundler 1.7.x and Ruby 2.7.x = wants bundler 2.1.x.

THANKS for all the hard work ya'll do on Ruby.

Hope this is helpful and informative,
Al

--_000_BYAPR05MB3957A8EFDD2D959A73274F4DC1190BYAPR05MB3957namp_-- --===============1747128144== Content-Type: text/plain; charset="us-ascii" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit Content-Disposition: inline Unsubscribe: --===============1747128144==--