From: "Eregon (Benoit Daloze)" Date: 2022-02-22T18:47:17+00:00 Subject: [ruby-core:107717] [Ruby master Feature#18597] Strings need a named method like `dup` that doesn't duplicate if receiver is mutable Issue #18597 has been updated by Eregon (Benoit Daloze). > and I want it to be as optimized as possible Also if that's the goal I would also avoid `.tap` and just use a local variable, and then `+@` works if that's really the semantics you want: ```ruby buffer = +some_object.send(a_method) buffer << "blah" ``` But the string interpolation seems more readable and is likely as efficient. ---------------------------------------- Feature #18597: Strings need a named method like `dup` that doesn't duplicate if receiver is mutable https://bugs.ruby-lang.org/issues/18597#change-96640 * Author: danh337 (Dan H) * Status: Open * Priority: Normal ---------------------------------------- This is related to #16295, but focuses only on the `.+@` part. Currently we can use `.dup` in a method chain when we need to mutate a String. However there are cases where the code's context *expects* the String to be mutated. In cases like this, `.dup` always works, but we don't want to duplicate a String that is already mutable. Since `.+@` looks more like an operator, it can be unintuitive in a method chain, so this is asking for a new named method that can be used in its place, instead of always `.dup`. For example: ``` def add_result_text(buffer, new_result) text = "#{new_result.count} #{new_result.input} #{do_fancy_calc(new_result)}\n" buffer.dup_if_immutable << text # ^^^^^^^^^^^^^^^^ new method? end buffer = "" # ...maybe immutable get_lots_of_results.each do |result| buffer = add_result_text(buffer, result) # In case it was dup'ed end ``` -- https://bugs.ruby-lang.org/ Unsubscribe: