From: Matthew Kerwin Date: 2016-02-17T08:12:08+10:00 Subject: [ruby-core:73857] Re: [Ruby trunk Feature#12075] some container#nonempty? --===============1189817409== Content-Type: multipart/alternative; boundary=001a113deec6a0e42c052bea6cd8 --001a113deec6a0e42c052bea6cd8 Content-Type: text/plain; charset=UTF-8 On 17/02/2016 3:31 AM, wrote: > > Issue #12075 has been updated by Rodrigo Rosenfeld Rosas. > > > The implementation doesn't have to be the same as the one implemented by ActiveSupport. I think it would be fine to simply check for nil? and empty?. But I'd like to keep the names present? and blank? anyway. > I'm sure the rails community would love methods with identical names but different behaviours to suddenly appear in the core. Personally I don't have a problem with 'nonempty?', since that's the trinary complement of 'empty' and 'full'. --001a113deec6a0e42c052bea6cd8 Content-Type: text/html; charset=UTF-8


On 17/02/2016 3:31 AM, <rr.rosas@gmail.com> wrote:
>
> Issue #12075 has been updated by Rodrigo Rosenfeld Rosas.
>
>
> The implementation doesn't have to be the same as the one implemented by ActiveSupport. I think it would be fine to simply check for nil? and empty?. But I'd like to keep the names present? and blank? anyway.
>

I'm sure the rails community would love methods with identical names but different behaviours to suddenly appear in the core.

Personally I don't have a problem with 'nonempty?', since that's the trinary complement of 'empty' and 'full'.

--001a113deec6a0e42c052bea6cd8-- --===============1189817409== Content-Type: text/plain; charset="us-ascii" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit Content-Disposition: inline Unsubscribe: --===============1189817409==--