From: "Dan0042 (Daniel DeLorme) via ruby-core" <ruby-core@...>
Date: 2024-12-01T02:51:36+00:00
Subject: [ruby-core:120073] [Ruby master Feature#20925] Allow boolean operators at beginning of line to continue previous line

Issue #20925 has been reported by Dan0042 (Daniel DeLorme).

----------------------------------------
Feature #20925: Allow boolean operators at beginning of line to continue previous line
https://bugs.ruby-lang.org/issues/20925

* Author: Dan0042 (Daniel DeLorme)
* Status: Open
----------------------------------------
I would like for this to become accepted syntax:

	condition1
	|| condition2
	
	condition1
	&& condition2
	
	condition1
	or condition2
	
	condition1
	and condition2
	
This is similar to how method chaining on the second line was added in Ruby 1.9

	expr
	.method
	
And it has the same advantage: when you have a multi-line expression, instead of hunting for the dot or boolean operator at the end of line1, it's right there at the beginning of line2, making the structure very obvious and readable. Please contrast:

	request.secret_key_base.present? &&
	  request.encrypted_signed_cookie_salt.present? &&
	  request.encrypted_cookie_salt.present? &&
	  request.use_authenticated_cookie_encryption
	
	request.secret_key_base.present?
	  && request.encrypted_signed_cookie_salt.present?
	  && request.encrypted_cookie_salt.present?
	  && request.use_authenticated_cookie_encryption

The first expression must rely on indentation to communicate the multi-line nature of the condition, and even then it's not as immediately obvious as the second expression, where we can see easily and immediately that this is a multi-line `&&` condition.

This syntax is also similar to how a trailing comma is allowed in arrays and hashes (and method calls since Ruby 1.9), with the same advantage. It makes for a cleaner diff when you add an element to the array/hash/conditional. Taking the previous example, imagine we are adding the condition `&& request.use_authenticated_cookie_encryption`. Now contrast the diff between the two styles:

	  request.secret_key_base.present? &&
	    request.encrypted_signed_cookie_salt.present? &&
	-    request.encrypted_cookie_salt.present?
	+    request.encrypted_cookie_salt.present? &&
	+   request.use_authenticated_cookie_encryption
	
	  request.secret_key_base.present?
	  && request.encrypted_signed_cookie_salt.present?
	  && request.encrypted_cookie_salt.present?
	+ && request.use_authenticated_cookie_encryption

Based on the above I would say this syntax is natural and consistent with existing Ruby syntactical elements, and would greatly improve code readability.



-- 
https://bugs.ruby-lang.org/
 ______________________________________________
 ruby-core mailing list -- ruby-core@ml.ruby-lang.org
 To unsubscribe send an email to ruby-core-leave@ml.ruby-lang.org
 ruby-core info -- https://ml.ruby-lang.org/mailman3/lists/ruby-core.ml.ruby-lang.org/