From: Gavin Sinclair Date: 2004-04-16T22:04:00+09:00 Subject: Re: Hash, ==, key-value comparison On Friday, April 16, 2004, 1:24:12 PM, Ara.T.Howard wrote: > On Fri, 16 Apr 2004, Yukihiro Matsumoto wrote: >> |* Change '==' method to compare only key-value pairs. >> |* Add Hash#=== method to act like current Hash#== >> >> They are possible options, along with >> >> * add new method (e.g. content_equal?) for membership equality. >> >> I'm not sure which one is the best way to go. > s/content_equal/equiv/ ? My turn: * Hash#== compares only the data * Hash#equiv? compares the data and the proc * Hash#=== is alias for Hash#key? The first two I think are matters of importance; the third one is just a nice idea. There are probably other, equally good, ideas for Hash#===. Cheers, Gavin