From: Bret Pettichord Date: 2004-04-16T02:22:34+09:00 Subject: Re: test / unit question: add "Warnings" to Failures and Errors At 10:29 AM 4/15/2004, Its Me wrote: >124 tests, 300 assertions, 0 failures, 0 errors, > 26 warnings (15 disabled, 8 skip, 2 todo, 1 other) >.. I argue against this. It's key to reduce visual clutter when you are running tests. They should be red or green. You shouldn't have to think about what you are seeing. The example above is confusing. And you shouldn't be using your tests as your to do list. Put them in comments and use Rdoc to extract them. Put them in your eclipse task list. Or build a separate system for tracking them, like Marick: require 'ruby-trace/util/todo' include Todo class Misnamed todo "Rename class Misnamed." include Math todo "Change square_root to handle negative args." def square_root(arg) todo 'This todo call happens every time the method is called.' sqrt(arg) end end if __FILE__ == $0 puts "The square root of 2 is #{Misnamed.new.square_root(2)}." end http://rubyforge.org/cgi-bin/viewcvs/cgi/viewcvs.cgi/wtr/scripting101/installs/timeclock/ruby-trace/doc/examples/todo-example.rb?rev=1.1.1.1&cvsroot=wtr&content-type=text/vnd.viewcvs-markup In fact i even think the distinction between failures and errors is tedious and unnecessary. Bret ______________________________________ Bret Pettichord, Software Tester Consultant - www.pettichord.com Author - www.testinglessons.com Blogger - www.io.com/~wazmo/blog Homebrew Automation Seminar April 30, Austin, Texas www.pettichord.com/training.html