From: Jim Weirich Date: 2004-04-13T02:02:29+09:00 Subject: Re: test / unit question: facility to mark some tests as "missing" or "incomplete" Its Me said: > I often find myself with some unit tests that run, and several more test > that I know I really should write but simply can't right now. Being > hopelessly forgetful and never reading my own comments, I would like some > way to enter such missing tests as stubs, so that test/unit will give a > "missing" or "incomplete" test message (but not count is as a test or > assertion failure). > > Is this doable? Does it make sense to do something like this? Sometimes when I wish to disable a test for a bit, I will change the name of a test from "test_xyz" to "xtest_xyz". A simple grep through the project identifies all such tests for later fixup. -- -- Jim Weirich jim@weirichhouse.org http://onestepback.org ----------------------------------------------------------------- "Beware of bugs in the above code; I have only proved it correct, not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)