From: Simon Strandgaard Date: 2004-03-22T21:44:47+09:00 Subject: Re: [rcr] rename append_features -> include_object On Mon, 22 Mar 2004 08:37:10 +0900, Yukihiro Matsumoto wrote: > In message "[rcr] rename append_features -> include_object" > on 04/03/22, Simon Strandgaard writes: > > |There is a saying: avoid asymmetry > | > |we have > |extended <-> included > |extend_object <-> "append_features" > | > |symmetry would be nice in ruby2 > > But append_features does "append features" to the class/module. The > name "include_object" is quite misleading. > true > I'd rather remove extend_object and append_features, which is older > than included/extended hooks. > Seems as the right choice. Thanks Matz. -- Simon Strandgaard