From: matz@... (Yukihiro Matsumoto) Date: 2004-03-22T08:37:10+09:00 Subject: Re: [rcr] rename append_features -> include_object Hi, In message "[rcr] rename append_features -> include_object" on 04/03/22, Simon Strandgaard writes: |There is a saying: avoid asymmetry | |we have |extended <-> included |extend_object <-> "append_features" | |symmetry would be nice in ruby2 But append_features does "append features" to the class/module. The name "include_object" is quite misleading. I'd rather remove extend_object and append_features, which is older than included/extended hooks. matz.