From: angus Date: 2004-03-02T20:38:42+09:00 Subject: Re: Arabic # -> Roman # (Was: TDD Roman Numeral tutorial in Ruby) > Hello Romans :-) > > I have done a solution to work with romans for the pleac cookbook > project, see: > > http://pleac.sourceforge.net/pleac_ruby/numbers.html > section "Working with Roman Numerals" > > It does also the opposite conversation. I have looked at other solutions > in other languages before writing this, and was quite happy to came up > with this algorithm, because it is so simple. And ruby lets me write > things like "2004.to_roman". Hi, A trivial readability improvement: Instead of for entry in @@romanlist sym, num = entry[0], entry[1] I think it's better to write for sym, num in @@romanlist Bye.