From: Simon Strandgaard Date: 2004-02-26T22:14:47+09:00 Subject: Re: proposal: debug keyword On Wed, 25 Feb 2004 13:16:50 +0100, Simon Strandgaard wrote: [snip] > I think this would be a good idea to have distributed with Ruby? > I am thinking of submitting an RCR, should I do this? > Question still stands, should I make an RCR out of it? Consideration if the name 'debug' is ok? Temporary enabling a global flag is more general, perhaps its better to make a temporary-set method temp_set $global_variable, :method Instead of naming it 'debug', then maybe name it temp_set_debug :method What should be in the RCR? the 'temp_set' thing or the 'debug' keyword thing? Sorry for rambling.. needs more input ;-) -- Simon Strandgaard