From: Paul Brannan Date: 2004-02-12T23:00:17+09:00 Subject: Re: ruby-dev summary: 22688-22826 On Thu, Feb 12, 2004 at 08:36:03AM +0900, Yukihiro Matsumoto wrote: > |For the record, I really like both of these ideas; they would completely > |eliminate the use I have for requirelocal/loadlocal in RubyTreasures. > > Any name suggestion? Well obviously I've been using "requirelocal" to mean "require a file with a path relative to the currently executing file". I have a lot of code that uses that method, but I've never liked the name. I do like the "require relative" idea proposed in [ruby-talk:92655]. Whatever method name is used, IMO it should indicate that the operation is similar in function to a require (so "import" and "include" are out -- though "include" is out for other reasons). Paul