From: nobu.nokada@... Date: 2004-02-03T14:18:26+09:00 Subject: Re: flip flop operator and assignment Hi, At Tue, 3 Feb 2004 13:08:50 +0900, Jamis Buck wrote: > So, instead of '..' and '...', how about something completely new, like > perhaps '--', or '~~'? Or even a new keyword, like 'flip' or > 'flipflop'? It would be nice to also somehow provide a way to access > some underlying objectified represention of the flip-flop, so that its > state could be queried and manipulated, Ruby already has both of unary and binary '-' operators, so the former will conflict. But '~' operator is only unary now, the later wouldn't. -- Nobu Nakada