From: matz@... (Yukihiro Matsumoto) Date: 2001-01-09T02:19:16+09:00 Subject: [ruby-talk:8883] Re: bug?? Hi, In message "[ruby-talk:8766] Re: bug??" on 01/01/07, Yasushi Shoji writes: |so having two ways (default and key_missing) to fix the same thing |isn't good IMHO. I think `default' and `key_missing' are to fix similar things, but somewhat different. They are corresponding to fetch(key,default) and fetch(key){...} respectively. But I think I'm not going with `key_missing'. Hash look up failure is more often comparing to method look up failure. The performance penalty is not tolerable, I think. Hash fall back by method I think Hash.new{...} is the way to go. matz.