From: Carl Youngblood Date: 2003-09-30T16:37:36+09:00 Subject: fastcgi permission error Hello, I'm trying to set up ruby-fastcgi on redhat 9. Everything seems to be set up right, but I get an error in my apache logs when I try to access a simple fcgi ruby script: [Tue Sep 30 01:15:54 2003] [alert] [client 127.0.0.1] (13)Permission denied: FastCGI: failed to connect to (dynamic) server "/var/www/cgi-bin/test.fcgi": something is seriously wrong, any chance the socket/named_pipe directory was removed?, see the FastCgiIpcDir directive A while back I was able to set up ruby-fcgi on a gentoo installation of linux without ever running into this problem. Does anybody have any ideas about what might be wrong? Thanks, Carl Youngblood P.S. In case it's helpful, here is the sample script I'm trying to run: #!/usr/local/bin/ruby require 'cgi' require 'fcgi' FCGI.each_cgi do |cgi| content = '' env = [] cgi.env_table.each do |k,v| env << [k,v] end env.sort! env.each do |k,v| content << %Q(#{k} => #{v}
\n) end cgi.out{content} end