From: "Kurt M. Dresner" Date: 2003-09-01T08:05:13+09:00 Subject: Re: Errors with a Ruby CGI script Okay, I found the problem. Turns out that Sun's chmod sucks a fat one. Had to mess with some stick-bits. Ick. -Kurt On Mon, Sep 01, 2003 at 07:59:04AM +0900, Kurt M. Dresner wrote: > I can't. I'm not root. However, I can go into smtp.rb and comment out > the line that says "require 'digest/md5'" > > I did this, and now my script works fine, however, will this be > detrimental to anyone else? > > -Kurt > > On Mon, Sep 01, 2003 at 07:57:31AM +0900, Daniel Carrera wrote: > > > So it seems that smtp.rb is having a hard time loading digest/md5. > > > Here's the deal, digest/md5 is in the directory: > > > > > > /p/lib/ruby/1.8/sparc-solaris2.8/digest/md5.so > > > > > > Is there any reason that it would look in that directory as a normal > > > user, but not as the www user? > > > > > > Odd. Can you su to 'www' and run `ruby -e 'require "digest/md5"' ` ? > > Does it give the same error? > > > > -- > > Daniel Carrera, Math PhD student at UMD. PGP KeyID: 9AF77A88 > > .-"~~~"-. > > / O O \ ATTENTION ALL PASCAL USERS: > > : s : > > \ \___/ / To commemorate the anniversary of Blaise Pascal's > > `-.___.-' birth (today) all your programs will run at half speed. > > > > > >======= End of Original Message =======< > >======= End of Original Message =======<