From: YANAGAWA Kazuhisa Date: 2003-07-25T18:31:59+09:00 Subject: Re: SWIG and "connect"? [Was: SWIG and char * parameters] In Message-Id: <200307241723.41949.ben@thingmagic.com> Ben Giddings writes: > When I name a function "connect" it behaves differently than if I name it > "connectTo". As far as I'm aware, connect isn't a reserved word in either > language, and no warnings are generated when I compile this. Maybe missing the point but.... 1. Are you sure SWIG wraps your version of connect()? 2. Redefine a system call / standard library function such as connect() is in general a bad idea. Hope this helps. -- kjana@dm4lab.to July 25, 2003 Speech is silver, silence is golden.