From: matz@... (Yukihiro Matsumoto) Date: 2003-06-27T13:46:52+09:00 Subject: Re: Warning error in YAML Hi, In message "Re: Warning error in YAML" on 03/06/27, Jason Creighton writes: |Personally, I think Object::Hash, Kernel::Hash are silly, and ::Hash is ugly. |Why not just say "Hash"? Sometimes you have to stand ugliness, when Hash may be overridden. class Foo Hash = {} def foo p Hash p ::Hash end end Foo.new.foo => {} Hash -- matz.